Skip to content

INFORMATION_SCHEMA needs to be in Uppercase in Fabric Lakehouse #110

Description

@craiha

When running commands like dbt --quiet run-operation generate_source against a Fabric Lakehouse it fails with the following error:

('42S02', "[42S02] [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Invalid object name 'lh_xxx.information_schema.tables'. (208) (SQLExecDirectW)")

When I edit the fabric__get_tables_by_pattern_sql macro and change the FROM statement to INFORMATION_SCHEMA.TABLES then it works.

Is it possible to for instance check the adapter to see if the table names should be in UPPERCASE?

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions