Repository navigation
Replies: 2 comments
I would not recommend touching the dropbear configuration, as you can leave yourself without being able to ssh into the device anymore. SSH password authentication is enabled, otherwise you would not be able to sign in as root with just the password.
|
0 replies
0 replies
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment

Uh oh!
There was an error while loading. Please reload this page.
Uh oh!
There was an error while loading. Please reload this page.
Hello! I wasn't sure how to get the attention of anyone that would know the answer, so please redirect me/my post as necessary.
I'm trying to set up a second user on an RM1 as part of the setup for this, apparently unmaintained project: https://github.com/helixhorned/ljremarkable .
I can add the user and set a password through busybox, but I cannot SSH into the new user account as password authentication fails (although I am entering the correct user acct password I just created). I suspect the problem is that SSH password authentication is not enabled on the RM1 but I haven't found a lot of info about where the dropbear config files are on the RM1 or how to edit them. Any ideas or suggestions would be appreciated! Thanks very much.
EDIT: Update: I used the old remarkable wiki guide to generate an SSH key pair (ssh-keygen), make a /.ssh/authorized_keys directory for the new user ($USER, shall we say), and copy the key to that directory. Now requesting an SSH session with $USER@10.11.99.1 opens a normal password prompt, but entering the account password gives the error "Permission denied, please try again."
All reactions